.NET Framework 1.1 installation Problems on Windows Vista

Windows vista does not have .NET framework 1.1 in it. If you want to run a legacy application developed using .NET framework 1.1, you need to download and install. But you often end up getting the following error:

“Application has generated an exception that could not be handled”

Resolution:

I found this link as a workaround to get this done. Yes, it works!